Lake Lavon Fishing
HomeForumHelpSearchLoginRegister
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 21, 2018, 02:02:41 PM

Pages: [1]   Go Down
Motor issue  (Read 1359 times)

Lunker
**

Posts: 91


Hey all, have been having an issue with my '03 Mercury 90hp 2 stroke.  The throttle rod keeps slipping out of the throttle arm when I throttle up.  I'm thinking I will try to replace the plastic clip it inserts into and hope that fixes the issue but if anyone has any suggestions or similar experiences I'm all ears!  Thanks in advance.

Eric




-------------------------
Jimmy Houston got it right: She doesn't have to be a '10,' as long as she likes to fish!
Top Bottom  

Lunker Extreme
***

Posts: 842


You Tube, I'm sure somebody else has had the same issue.  Just a suggestion.




-------------------------
Safe Floor North Texas
www.safe-floor.com
Top Bottom  

Lunker
**

Posts: 91


Found another forum where someone else was having the same problem. Just need to replace the clips: $12... not $90 an hour for marine mechanic.  rockon




-------------------------
Jimmy Houston got it right: She doesn't have to be a '10,' as long as she likes to fish!
Top Bottom  

Minnow
*

Posts: 6


If it is what I think it is...it is a $7 item and we have it in stock!!
Call us 469-221-2564



Top Bottom  

Lunker
**

Posts: 91


Fixed today.  The part was a "bushing" that connects the throttle rod onto the throttle cam and throttle arm (one bushing on cam and one on arm; replaced both).  As power pro said it is $6-7 item and I think definitely worth replacing or having an extra in the glove box if your motor is a couple years old.  The part is small and would fit on a quarter but it is clearly the weakest link in the linkage as mine was noticeably worn compared to the new part.




-------------------------
Jimmy Houston got it right: She doesn't have to be a '10,' as long as she likes to fish!
Top Bottom  
Pages: [1]   Go Up


Jump to:  

Powered by SMF 1.1.18 | SMF © 2013, Simple Machines